cbys.net
当前位置:首页 >> slF4j Api 1.5.11.jAr >>

slF4j Api 1.5.11.jAr

有很多啊,有Log4j,LogBack,甚至JDK自带的Logger都是slf4j的实现类。 你如果要使用Log4j,那么除了slf4j-api外还需要一个slf4j-log4j12(或slf4j-log4j13这个根据你的Log4j的版本来),你如果要使用JDK作为实现的话,那么除了slf4j-api外,还...

在引用了这个包中的class的地方,删除重新引用一次。

slf4j-api-1.5.8.jar不就是包么,要下载这个包,百度一下不就有了。

-sources是源码

slf4j:Simple Logging Facade for Java,为java提供的简单日志Facade。Facade:门面,更底层一点说就是接口。他允许用户以自己的喜好,在工程中通过slf4j接入不同的日志系统。更直观一点,slf4j是个数据线,一端嵌入程序,另一端链接日志系统,...

slf4j.nop.jar是slf-api.jar其相应的接口实现, 把slf的接口对到log4j的实现 把slf的实现slf4j-nop-1.5.8.jar去掉,添加log4j的实现log4j-1.2.15.jar,再添加一个slf-api和log4j转换器slf4j-log4j12-1.5.8.jar. 把slf的接口转换成log4j的接口.最后...

slf4j是hibernate的日志接口,通常我们用log4j.jar来实现hibernate的记录日志功能,slf4j-log4j.jar可以看成是用来把slf4j的接口转换成适合log4j的接口的一个适配器。

你先看看你的slf4j-log4j12-1.2.jar包里面有没有org/slf4j/impl/MarkerIgnoringBase这个类,如果有 你再看看你的工程的BuildPath有没有应用这个包

重新builtpath一下?刷新一下项目。clean一下

错误显示你的slf4j的包版本有点老,它需要1.6版本的,你的接口貌似是1.5.8版本的

网站首页 | 网站地图
All rights reserved Powered by www.cbys.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com